Show newer

MastodonをFedora 37にインストールするまとめ
・opensslを1.1.1.1qに入れ替え
・libicu67を手動インストール
・gemをインストールし直し
・ruby 3.0.3をインストールし直し
・nginxのsystemd serviceにExecStartPost=/usr/bin/chown -R mastodon:mastodon /var/lib/nginx/を追記

前より難易度上がってますね
Fedora 35まではスムーズにいけた

@noellabo

メンテニャンスbotの「正常に復帰しました」を信じていいか分からんが、SQLで状態取得してるので多分大丈夫w

メメンテ終わり
メンテニャンスちゃんありがとう

あ boosted

atsuchan.pageのストリーミングレプリケーションは正常に復帰しました。

あ boosted

atsuchan.pageのストリーミングレプリケーションに異常発生しました。状況確認してください。

systemctlでMastodonを生き返らせるようにしてたんですが、パッケージマネージャーにoverrideされましたね、ぐぬぬ

パッケージマネージャーに殺されるMastodonににゃってる(直した

次にサブデータベースサーバーをメンテニャンスします

おっけatsuchan.page全リージョン復帰

東京リージョンロードバランサー起動よし

あ、atsuchan.page 東京リージョンメンテニャンス中にゃので、アクセスの半分は成功して半分は失敗します(ラウンドロビン)

misskeyのコードをどんどん書き換えてsakura-telにコントリビュートしていってる

api/metaとかapi/server-infoとかどう考えてもPOSTじゃにゃくてGETにゃのでは

misskey v12のAPIはPOSTじゃにゃくていいやつをGETにしたいけどめっちゃ難しい

こののインスタンスはMastodonもPGroongaもNginxもNetdataも自力でビルドしてインストールにゃので心配事が多い

うちのノートPCとかUSBメモリとかは全部暗号化かけてますね、心配事が減っていい

あ boosted

ボリュームの上に暗号化レイヤーを挟んで/dev/mapperにのせて、そこに改めてパーティションを切るとかLVM載せるとかするのですわ

Show thread

Azureのクレジットそんにゃににゃいのだわ

うちのリレーサーバーにゃんで落ちてるのかと思ったけど、配送先のエラーで過負荷ににゃってるっぽい、遮断すれば直る、AzureのStandard B1sで動いてるから解決は諦めた

Show older
atsuchan.page (Mastodon v3)

Mastodon development environment for atsuchan